Browse Source

update packages

windhamdavid 2 years ago
parent
commit
2972352ce8
3 changed files with 17 additions and 15 deletions
  1. 1 1
      app.js
  2. 2 2
      gulpfile.js
  3. 14 12
      package.json

+ 1 - 1
app.js

@@ -12,7 +12,7 @@ var errorHandler = require('errorhandler');
 var events = require('events');
 var http = require('http');
 var path = require('path');
-var fs = require('fs');
+var fs = require('graceful-fs');
 var logger = require('morgan');
 
 var _ = require('lodash');

+ 2 - 2
gulpfile.js

@@ -121,7 +121,7 @@ gulp.task('watch', function() {
 var syncTask = function() {
     browserSync.init({
         proxy: {
-          target: 'https://juryd.macs',
+          target: 'https://juryd-app.macs',
           ws: true
         },
         https: true,
@@ -148,7 +148,7 @@ var nodemonTask = function() {
       './controllers',
       './app.js'
     ],
-    ext: 'js jade hbs html css'
+    ext: 'js jade pug hbs html css'
   });
 };
 

+ 14 - 12
package.json

@@ -13,30 +13,32 @@
     "node": ">=4.0.0"
   },
   "dependencies": {
-    "async": "^1.5.0",
-    "bcrypt-nodejs": "0.0.3",
+    "async": "^2.4.0",
+    "bcrypt-nodejs": "^0.0.3",
     "bcryptjs": "^2.3.0",
-    "body-parser": "^1.14.1",
+    "body-parser": "^1.15.2",
     "compression": "^1.6.0",
-    "connect-mongo": "^0.8.2",
+    "connect-mongo": "^1.3.2",
     "cookie-parser": "^1.3.5",
     "errorhandler": "^1.4.2",
     "express": "^4.13.3",
     "express-flash": "0.0.2",
     "express-handlebars": "^2.0.1",
     "express-session": "^1.12.1",
-    "express-validator": "^2.18.0",
-    "file-stream-rotator": "0.0.6",
-    "fs": "0.0.2",
-    "lodash": "^3.10.1",
+    "express-validator": "^3.2.0",
+    "file-stream-rotator": "^0.1.0",
+    "graceful-fs": "4.1.11",
+    "install": "^0.10.1",
+    "lodash": "^4.17.4",
     "lusca": "^1.3.0",
     "method-override": "^2.3.5",
-    "mongoose": "^4.2.9",
-    "morgan": "~1.6.1",
-    "nodemailer": "^1.10.0",
+    "mongoose": "^4.9.8",
+    "morgan": "^1.8.1",
+    "nodemailer": "^4.0.1",
     "passport": "^0.3.2",
     "passport-local": "^1.0.0",
-    "serve-favicon": "~2.3.0"
+    "pug": "^2.0.0-rc.1",
+    "serve-favicon": "^2.4.2"
   },
   "devDependencies": {
     "browser-sync": "^2.10.0",